employees not showing up in the org chart

by JoePoliti » Mon Jun 12, 2017 1:21 pm

We are finding that many employees do not show up in the Org chart. I have it set to connect to the Profile service. My filter is setup as follows:
function(itemData){

//You can get field values like this: itemData["Department"]
//Example: return itemData["Department"] == "Marketing";
return itemData["SPS-HideFromAddressLists"] != "True";
return true;
}

I have tried to add the missing user to the script by appending the following line:
itemData["AccountName"].contains("missingperson@dynatrace.com;

Of course this fix does not scale well as we are finding more and more users missing. On a separate site collection I installed the native Organization Browser and we do not have this issue. In addition I installed a trial version of another Organization Chart app from the app store and this too worked. I can see the missing users in SharePoint and their profiles are visible but the only place I cannot find them either by search or navigating is in the Plumsail app. Any help would be appreciated.
User avatar
JoePoliti
 
Posts: 5
Joined: Mon Oct 17, 2016 6:17 pm

by andrelima » Tue Jun 13, 2017 7:01 pm

Hello,
Thank you for your message.

Please try removing your filtration rules and see if you get the expected behavior.

I'll be happy to hear your results.

Best regards,
Andre Lima
Plumsail Team.
User avatar
andrelima
 
Posts: 60
Joined: Wed Apr 19, 2017 2:06 pm


Return to Org Chart for Office 365

cron