Workflow Actiom get suspended when using Render Text Templat

by amubarak » Tue Oct 06, 2015 12:33 am

i am trying to render text template based on the following Get Item by Query:

<View Scope="RecursiveAll">
<Query>
<Where>
<And>
<Eq>
<FieldRef Name='Assign_x0020_To' />
<Value Type='Text'>34355</Value>
</Eq>
<Neq>
<FieldRef Name='The_x0020_Task_x0020_Status' />
<Value Type='Text'>Completed</Value>
</Neq>
</And>
</Where>
</Query>
<ViewFields>
<FieldRef Name='Task_x0020_Title' />
<FieldRef Name='Opened_x0020_By' />
<FieldRef Name='Assign_x0020_Date' />
<FieldRef Name='TaskDueDate' />
<FieldRef Name='The_x0020_Task_x0020_Status' />
<FieldRef Name='TaskURL' />
</ViewFields>
<QueryOptions />
</View>

and Template Content is simple as the following:

The Tasks consists of the following :
<ul>
{{#each Documents}}
<li><a href="{{CurrentItem.TaskURL}}">{{FieldValues.Task_x0020_Title}}</a></li>
{{/each}}
</ul>


however , Workflow Action get suspended with following Error


RequestorId: 1833ee6f-785d-bc02-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["54"],"SPRequestGuid":["1833ee6f-785d-bc02-92fd-4d4b7b24de61"],"request-id":["1833ee6f-785d-bc02-92fd-4d4b7b24de61"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Vary":["Accept-Encoding"],"Cache-Control":["max-age=0, private"],"Date":["Tue, 06 Oct 2015 00:20:49 GMT"],"Set-Cookie":["BIGipServer~infra_partition~Sharepoint_Internal.app~Sharepoint_Internal_pool=2433351690.20480.0000; path=\/"],"Server":["Microsoft-IIS\/8.0"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)


can you help ?
amubarak
 
Posts: 8
Joined: Mon Sep 28, 2015 11:11 am

by Roman Rylov » Tue Oct 06, 2015 12:20 pm

Hello amubarak

I may suppose the workflow was suspended in the Log to history workflow action.
Could you please check it.
You can find more information in the following article SharePoint 2013 Designer and Workflow Tips, Tricks & Traps, please pay attention on the first section "Do not log Dictionary variable to Log to History"
User avatar
Roman Rylov
 
Posts: 325
Joined: Tue Nov 11, 2014 6:25 pm

by amubarak » Tue Oct 06, 2015 12:34 pm

Dear Roman;

i dont have any log to history action ...

Kindly check the Attached

RenderIssue.png
RenderIssue.png (12.21 KiB) Viewed 887 times
amubarak
 
Posts: 8
Joined: Mon Sep 28, 2015 11:11 am

by Roman Rylov » Tue Oct 06, 2015 12:40 pm

amubarak ,

OK, I see. Can we have a screen sharing session to diagnose the issue?
Please write me at rylov@plumsail.com to schedule it.
User avatar
Roman Rylov
 
Posts: 325
Joined: Tue Nov 11, 2014 6:25 pm


Return to Workflow Actions Pack for SharePoint 2013