Saving a list as a template - workflow not attached

by gizmo3k » Tue Oct 25, 2016 3:06 pm

Good afternoon,

I am trying to create a site template so that I can quickly create new sites for our users. I am having some issues saving some of our documents libraries and lists as templates.

This only seems to affect lists and libraries that have workflows using functions from the workflow action pack.

When we save the library, any associated workflows are not saved as part of the template.

If we try saving the whole site without content, this works fine. If we try to save the site as a template including content (and thus including workflows), we get an error: System.Net.WebException: The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.

Is there any way to include these workflows in a list template, so we can re-use these lists? If not, is there an easy way to package up and deploy our workflows so we can then re-attach them to the lists after site creation?

Thanks
gizmo3k
 
Posts: 9
Joined: Fri Aug 12, 2016 2:00 pm

by Roman Rylov » Thu Oct 27, 2016 10:33 am

Hello Gizmo,

If we try saving the whole site without content, this works fine. If we try to save the site as a template including content (and thus including workflows), we get an error: System.Net.WebException: The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.

Is there any way to include these workflows in a list template, so we can re-use these lists? If not, is there an easy way to package up and deploy our workflows so we can then re-attach them to the lists after site creation?


I think this is SharePoint limitations, however, we have experimented with site templates last year, please check out the following article: Deploy custom SharePoint 2013 workflows with site template

Also, you can save the workflow separately using "Save as Template" button on the ribbon.
User avatar
Roman Rylov
 
Posts: 330
Joined: Tue Nov 11, 2014 6:25 pm

by gizmo3k » Thu Oct 27, 2016 2:03 pm

Thanks Roman,

Since posting this, I tried saving the (reusable) workflow as a template. I then uploaded it as a solution to a new site collection, and activated the feature, however I was still unable to assign this workflow to a list or library - it wasn't in the list to select it.

I will have a read of that article now.

Thanks again

Alan
gizmo3k
 
Posts: 9
Joined: Fri Aug 12, 2016 2:00 pm

by gizmo3k » Wed Nov 02, 2016 1:24 pm

Good afternoon,

More testing carried out - I have saved the reusable workflow as a template, run the fix on the article mentioned previously, and am still unable to use the workflow in the new site/site collection.

I tried creating a standard SharePoint 2013 workflow without any Workflow Action Pack actions, and was able to move this fine after saving it as a template - it must be something in the Workflow Action Pack that is causing it to not be available.

Could this be looked into? It is severely limiting the usefulness of the Workflow Action Pack, as I am unable to reuse my workflows in new sites, something which is vital to our solution.

Thanks

Gizmo3k
gizmo3k
 
Posts: 9
Joined: Fri Aug 12, 2016 2:00 pm

by Roman Rylov » Tue Nov 08, 2016 1:25 pm

gizmo3k

I would greatly appreciate if you send us your template at support@plumsail.com, in that case we could research it.
User avatar
Roman Rylov
 
Posts: 330
Joined: Tue Nov 11, 2014 6:25 pm


Return to Workflow Actions Pack for Office 365